Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[EX/QFX] VLAN not working when VLANs name contains "-vlan"

0

0

Article ID: KB35371 KB Last Updated: 24 Jun 2020Version: 2.0
Summary:

On EX/QFX Series switches, when the VLAN name contains "-vlan" and when you add an interface to this VLAN, the VLAN does not work.

This article suggests a workaround to resolve this issue.

 

Symptoms:

On EX/QFX Series switches, when the VLAN name contains "-vlan," the VLAN does not work when you subsequently add an interface to this VLAN by using the apply group configuration. This is demonstrated as follows:

  1. For this example, we use a QFX5220 device that runs Junos OS release 19.3R1.

  2. The device has a VLAN named "native-vlan-group" and consists of vlan-id list [5-50 99]. The interface is set by using the apply group configuration, but the VLAN setting does not work and hence when we check the VLANs, the interfaces are not found.

  3. The configuration of the VLAN "native-vlan-group" is given below:

root@QFX5220> show configuration vlans
default {
vlan-id 1;
}
native-vlan-group {
vlan-id-list [ 5-50 99 ];
}
root@QFX5220> show configuration groups test-ports
interfaces {
<*> {
native-vlan-id 99;
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members native-vlan-group;
}
}
root@QFX5220> show vlans 99

Routing instance        VLAN name             Tag          Interfaces
default-switch          native-vlan-group-vlan-0099 99

There is no interface in VLAN 99 and the interfaces are not found in other VLANS that belong to the VLAN list 5-50.

Cause:

It is a day-1 issue.

Solution:

To workaround the issue, change the name from native-vlan-group to native_vlan_group. Without "-vlan" in the VLAN name, this issue will be resolved.

Modification History:
2020-06-20: Article reviewed for accuracy. Article is correct and complete.
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search