Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[ACX] How to configure implicit QinQ

0

0

Article ID: KB35761 KB Last Updated: 06 May 2020Version: 1.0
Summary:

This article provides an alternative way to configure QinQ on ACX platforms without using input-vlan-map/output-vlan-map.

On the customer vlan (C-VLAN) facing side, the ACX does not expect aspecific VLAN. Any traffic comes in will get pushed by a service VLAN (S-VLAN). It's equivalent to "vlan-id-range 1-4094".  Outgoing traffic will pop the S-VLAN.

Solution:

Topology: 

MX xe-0/1/0 <-- S-VLAN --> xe-0/0/0 ACX xe-0/0/1 <-- C-VLAN >--> EX 

MX>show configuration interfaces:

xe-0/1/0 {
flexible-vlan-tagging;
encapsulation flexible-ethernet-services;
unit 0 {
encapsulation dix;
vlan-tags outer 917 inner 15;
family inet {
address 10.10.10.2/30;
}
}
}

ACX> show configuration interfaces 
xe-0/0/0 {
description nni;
flexible-vlan-tagging;
encapsulation flexible-ethernet-services;
unit 917 {
encapsulation vlan-bridge;
vlan-id 917;
family ethernet-switching;
}
}
xe-0/0/1 {
description uni;
encapsulation ethernet-bridge;
unit 0 {
family ethernet-switching {
}
}
}

ACX> show configuration vlans         
acx-test {
vlan-id 917;
interface xe-0/0/0.917;
interface xe-0/0/1.0;
}

EX> show configuration interfaces 
xe-0/0/1 {
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members test;
}
}
}
}
irb {
unit 15 {
family inet {
address 10.10.10.1/30;
}
}
}

EX> show configuration vlans 
test {
vlan-id 15;
l3-interface irb.15;
}


Verification: 

ACX> show interfaces xe-0/0/1.0    
  Logical interface xe-0/0/1.0 (Index 550) (SNMP ifIndex 525)
    Flags: Up SNMP-Traps 0x24004000 VLAN-Tag [  ] In(push 0x8100.917) Out(pop)  Encapsulation: Ethernet-Bridge
    Input packets : 19581
    Output packets: 18400
    Protocol eth-switch, MTU: 9216
      Flags: Is-Primary

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search