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[Security Director] Import Policy from Device Fails 'An error occurred while requesting the data'

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Article ID: KB35936 KB Last Updated: 17 Jun 2020Version: 1.0
Summary:

This article explains why Policy Import from the Device to Security Director may fail.

Symptoms:

While trying to import policies from the device to the Security Director under Security Director > Device > Security Devices > Import > Import Configuration, policy import fails with the following error:

'An error occurred while requesting the data'

Example:

Cause:

An unsupported character exists in the device configuration.

Example error in CLI logs:

2019-10-16 17:10:11,637 ERROR [net.juniper.sm.imports.bean.DeviceImportManagerHandler] (ajp-space-0050568b501f/10.214.6.107:8009-11)
Failed in Merging effective and raw Config : com.ctc.wstx.exc.WstxUnexpectedCharException: Illegal character ((CTRL-CHAR, code 12))
at [row,col {unknown-source}]: [8724,176]

Error logs indicates the presence of a unsupported character in the configuration of the firewall. As a result, import fails.
Unfortunately, the error may not clearly identify the problem character.

Note: If the Highlighted message is not found in Space CLI logs during the time of import. A different issue has occurred, contact JTAC for assistance.

Example with unexpected characters (Examples may not display depending on your browser/OS interpretation):

set security policies from-zone zone1 to-zone zone2 policy rulename description "ПрK? 
set security policies from-zone zone1 to-zone zone2 policy rulename description "5PF?? 
set security policies from-zone zone1 to-zone zone2 policy rulename description "!?їоС§:OSCE"

The problem characters are most likely found in descriptions, but not always.

Solution:
  • Review Device configuration for any non nonstandard characters.
  • Remove problem characters from device configuration and commit.
  • Attempt to import again.
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