Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

vSRX upgrade fails with error '-lt: unexpected operator'

0

0

Article ID: KB36127 KB Last Updated: 31 Jul 2020Version: 1.0
Summary:

This article discusses the issue where vSRX upgrade fails using the tgz package.

Symptoms:

While performing software upgrade using the tgz package, the following error was encountered:

Admin@vsrx>request system software add /var/tmp/junos-vsrx-x86-64-20.1R1.11.tgz no-copy no-validate reboot

Verified junos-vsrx-x86-64-20.1R1.11 signed by PackageProductionECP256_2020 method ECDSA256+SHA256
[: -lt: unexpected operator
192.168.1.1: Can't assign requested address
192.168.1.1: Can't assign requested address
[: : bad number

WARNING:     This package will load JUNOS 20.1R1.11 software.
WARNING:     It will save JUNOS configuration files, and SSH keys
WARNING:     (if configured), but erase all other files and information
WARNING:     stored on this machine.  It will attempt to preserve dumps
WARNING:     and log files, but this can not be guaranteed.  This is the
WARNING:     pre-installation stage and all the software is loaded when
WARNING:     you reboot the system.

Saving the config files ...
usage: basename string [suffix]
basename [-a] [-s suffix] string [...]
not found, install abort!
ERROR: upgrade failed
ERROR: Failed to add junos-vsrx-x86-64-20.1R1.11.tgz
Solution:

This is seen when the image being used for the upgrade is not a supported image for the platform. vSRX2.0 and vSRX3.0 are two different offerings by Juniper which use different images and upgrade packages.

Example:

  • vSRX2.0 image - junos-vsrx-x86-64-18.3R1.8.tgz
  • vSRX3.0 image - junos-install-vsrx3-x86-64-19.1R2.7.tgz

If the vSRX3.0 upgrade was attempted using vSRX2.0 upgrade package, you will come across this error. Ensure that you are using the correct image based on the platform for the upgrade.

Note: To identify whether you are running a vSRX2.0 or vSRX3.0, refer to KB33572 - Overview of the available virtual SRX models, vSRX and vSRX 3.0
 

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search