Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[MX/QFX] Example - How to configure VXLAN/EVPN by using routing instances as clients

0

0

Article ID: KB36250 KB Last Updated: 14 Oct 2020Version: 1.0
Summary:

This article demonstrates how to configure a router with two virtual routing instances as clients to traverse an EVPN/VXLAN environment with the help of an example.

 

Symptoms:

Topology Diagram

In this example, we are using two clients:

  • VR-20  20.20.20.1/24

  • VR-40  40.40.40.1/24

The goal is to ping from 20.20.20.1/24 to 40.40.40.1/24 and the other way round.

The two VLANs used here have the ID 20 and 40 and VNI and VTEP connections for the tunnel, respectively.

LEAF 1 is a router with a virtual switch instance to support IRBs for the two clients.

 

Solution:

Configuration

LEAF 1

  1. Configure IRBs for the clients on Leaf 1.

set interfaces irb unit 20 proxy-arp
set interfaces irb unit 20 family inet address 20.20.20.100/24
set interfaces irb unit 40 proxy-arp
set interfaces irb unit 40 family inet address 40.40.40.100/24
  1. Configure the IP Fabric between Leaf 1 and Spine 1 as well as the Underlay and Overlay.

set interfaces xe-0/0/0 description TO-SPINE-1
set interfaces xe-0/0/0 unit 0 family inet address 10.10.10.1/30

set interfaces lo0 unit 0 family inet address 101.101.101.1/32
set routing-options router-id 101.101.101.1
set routing-options autonomous-system 65000

set protocols bgp group underlay type external
set protocols bgp group underlay export lo0
set protocols bgp group underlay peer-as 65001
set protocols bgp group underlay local-as 65002
set protocols bgp group underlay neighbor 10.10.10.2

set protocols bgp group overlay type internal
set protocols bgp group overlay local-address 101.101.101.1
set protocols bgp group overlay family evpn signaling
set protocols bgp group overlay local-as 65000
set protocols bgp group overlay neighbor 100.100.100.1

As you can see, there is a policy called lo0. This is because an export policy has been created to export lo0 instead of using OSPF or a dynamic protocol under the underlay to connect the lo0s.

set policy-options policy-statement lo0 term 1 from interface lo0.0
set policy-options policy-statement lo0 term 1 then accept
  1. Configure communities and VRF targets for VNIs and the IP Fabric.

set policy-options community FABRIC members target:65000:1
set policy-options community vni20 members target:65000:20
set policy-options community vni40 members target:65000:40

set policy-options policy-statement evpn-import term fabric from community FABRIC
set policy-options policy-statement evpn-import term fabric from community vni20
set policy-options policy-statement evpn-import term fabric from community vni40
set policy-options policy-statement evpn-import term fabric then accept
  1. Apply the evpn-import policy under routing instance type "virtual switch".

set routing-instances evpn1 vtep-source-interface lo0.0
set routing-instances evpn1 instance-type virtual-switch
set routing-instances evpn1 route-distinguisher 101.101.101.1:1
set routing-instances evpn1 vrf-import evpn-import
set routing-instances evpn1 vrf-target target:65000:1
set routing-instances evpn1 protocols evpn encapsulation vxlan
set routing-instances evpn1 protocols evpn extended-vni-list 20
set routing-instances evpn1 protocols evpn extended-vni-list 40
set routing-instances evpn1 protocols evpn vni-options vni 20 vrf-target target:65000:20
set routing-instances evpn1 protocols evpn vni-options vni 40 vrf-target target:65000:40
set routing-instances evpn1 protocols evpn multicast-mode ingress-replication
set routing-instances evpn1 protocols evpn default-gateway advertise
set routing-instances evpn1 bridge-domains v20 vlan-id 20

set routing-instances evpn1 bridge-domains v20 routing-interface irb.20
set routing-instances evpn1 bridge-domains v20 vxlan vni 20
set routing-instances evpn1 bridge-domains v40 vlan-id 40
set routing-instances evpn1 bridge-domains v40 routing-interface irb.40
set routing-instances evpn1 bridge-domains v40 vxlan vni 40
  1. Configure Spine 1.

set interfaces xe-0/0/1 description TO-LEAF-1
set interfaces xe-0/0/1 unit 0 family inet address 10.10.10.2/30
  1. Configure the QFX device to allow VLANs over the trunk to the client.

set interfaces xe-0/0/2 description TO-CLIENT
set interfaces xe-0/0/2 unit 0 family ethernet-switching interface-mode trunk
set interfaces xe-0/0/2 unit 0 family ethernet-switching vlan members V20
set interfaces xe-0/0/2 unit 0 family ethernet-switching vlan members V40
  1. Configure the Underlay and Overlay IP Fabric.

set interfaces lo0 unit 0 family inet address 100.100.100.1/32
set routing-options router-id 100.100.100.1
set routing-options autonomous-system 65000
set protocols bgp group underlay type external
set protocols bgp group underlay export lo0
set protocols bgp group underlay peer-as 65002
set protocols bgp group underlay local-as 65001
set protocols bgp group underlay neighbor 10.10.10.1

set protocols bgp group overlay type internal
set protocols bgp group overlay local-address 100.100.100.1
set protocols bgp group overlay family evpn signaling
set protocols bgp group overlay local-as 65000
set protocols bgp group overlay neighbor 101.101.101.1

You must export lo0 and configure it under the Underlay on Spine 1.

set policy-options policy-statement lo0 from interface lo0.0
set policy-options policy-statement lo0 then accept
  1. Configure communities and VRF targets for VNIs and the IP Fabric.

set policy-options policy-statement evpn-import term fabric from community FABRIC
set policy-options policy-statement evpn-import term fabric from community vni20
set policy-options policy-statement evpn-import term fabric from community vni40
set policy-options policy-statement evpn-import then accept

set policy-options community FABRIC members target:65000:1
set policy-options community vni20 members target:65000:20
set policy-options community vni40 members target:65000:40‚Äč
  1. Apply the evpn-import policy.

set protocols evpn vni-options vni 20 vrf-target export target:65000:20
set protocols evpn vni-options vni 40 vrf-target export target:65000:40
set protocols evpn encapsulation vxlan
set protocols evpn multicast-mode ingress-replication
set protocols evpn extended-vni-list 20
set protocols evpn extended-vni-list 40

set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 100.100.100.1:1
set switch-options vrf-import evpn-import
set switch-options vrf-target target:65000:1
set switch-options vrf-target export target:65000:1
  1. Configure VXLAN under the VLANs.

set vlans V20 vlan-id 20
set vlans V20 vxlan vni 20
set vlans V40 vlan-id 40
set vlans V40 vxlan vni 40

The P router configuration for both routing instance clients is as follows:

set routing-instances VR-20 instance-type virtual-router
set routing-instances VR-20 interface xe-0/0/0.20
set routing-instances VR-20 routing-options static route 0.0.0.0/0 next-hop 20.20.20.100
set interfaces xe-0/0/0 unit 20 vlan-id 20
set interfaces xe-0/0/0 unit 20 family inet address 20.20.20.1/24

set routing-instances VR-40 instance-type virtual-router
set routing-instances VR-40 interface xe-0/0/0.40
set routing-instances VR-40 routing-options static route 0.0.0.0/0 next-hop 40.40.40.100
set interfaces xe-0/0/0 unit 40 vlan-id 40
set interfaces xe-0/0/0 unit 40 family inet address 40.40.40.1/24

The same physical interface has been used to connect both clients to Spine 1.

set interfaces xe-0/0/0 description TO-SPINE1
set interfaces xe-0/0/0 flexible-vlan-tagging
set interfaces xe-0/0/0 encapsulation flexible-ethernet-services

How to Test the Configuration

  1. From router P, use the source address 20.20.20.1 in routing instance VR-20 to ping the other client with IP address 40.40.40.1 in VR-40.

root@P# run ping 40.40.40.1 routing-instance VR-20 source 20.20.20.1
PING 40.40.40.1 (40.40.40.1): 56 data bytes
64 bytes from 40.40.40.1: icmp_seq=0 ttl=63 time=0.901 ms
64 bytes from 40.40.40.1: icmp_seq=1 ttl=63 time=0.851 ms
64 bytes from 40.40.40.1: icmp_seq=2 ttl=63 time=0.843 ms

SPINE 1

root@SPINE-1# run show interfaces terse |match vtep
vtep up up
vtep.32768 up up
vtep.32769 up up eth-switch

The MAC address representing both clients is 00:23:9c:9d:2a:94. Remember that xe-0/0/0 has two logical unit interfaces, 20 and 40, which are assigned to two different virtual routing instances.

root@SPINE-1# run show ethernet-switching table

MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static
           SE - statistics enabled, NM - non configured MAC, R - remote PE MAC, O - ovsdb MAC)

Ethernet switching table : 4 entries, 4 learned
Routing instance : default-switch
   Vlan                MAC                 MAC      Logical                Active
   name                address             flags    interface              source
   V20                 00:23:9c:9d:2a:94   D        xe-0/0/2.0
   V20                 80:71:1f:95:9f:f0   D        vtep.32769             101.101.101.1
   V40                 00:23:9c:9d:2a:94   D        xe-0/0/2.0
   V40                 80:71:1f:95:9f:f0   D        vtep.32769             101.101.101.1

Tunnel Endpoint Output 

root@SPINE-1# run show ethernet-switching vxlan-tunnel-end-point source
Logical System Name       Id  SVTEP-IP         IFL   L3-Idx
<default>                 0   100.100.100.1    lo0.0    0
    L2-RTT                   Bridge Domain              VNID     MC-Group-IP
    default-switch           V20+20                     20       0.0.0.0
    default-switch           V40+40                     40       0.0.0.0

{master:0}[edit]
root@SPINE-1# run show ethernet-switching vxlan-tunnel-end-point remote
Logical System Name       Id  SVTEP-IP         IFL   L3-Idx
<default>                 0   100.100.100.1    lo0.0    0
 RVTEP-IP         IFL-Idx   NH-Id
 101.101.101.1    558       1729
    VNID          MC-Group-IP
    20            0.0.0.0
    40            0.0.0.0

Another way to check the vxlan-tunnel-end-point is by using the following command:

{master:0}[edit]
root@SPINE-1# run show interfaces vtep extensive |match "logical | end"
  Logical interface vtep.32768 (Index 557) (SNMP ifIndex 556) (HW Token 3) (Generation 147)
    VXLAN Endpoint Type: Source, VXLAN Endpoint Address: 100.100.100.1, L2 Routing Instance: default-switch, L3 Routing Instance: default
  Logical interface vtep.32769 (Index 558) (SNMP ifIndex 560) (HW Token 5) (Generation 148)
    VXLAN Endpoint Type: Remote, VXLAN Endpoint Address: 101.101.101.1, L2 Routing Instance: default-switch, L3 Routing Instance: default

{master:0}[edit]
root@SPINE-1# run show ethernet-switching vxlan-tunnel-end-point remote mac-table

MAC flags (S -static MAC, D -dynamic MAC, L -locally learned, C -Control MAC
           SE -Statistics enabled, NM -Non configured MAC, R -Remote PE MAC, P -Pinned MAC)

Logical system   : <default>
Routing instance : default-switch
 Bridging domain : V20+20, VLAN : 20, VNID : 20
   MAC                 MAC      Logical          Remote VTEP
   address             flags    interface        IP address
   80:71:1f:95:9f:f0   D                         101.101.101.1

MAC flags (S -static MAC, D -dynamic MAC, L -locally learned, C -Control MAC
           SE -Statistics enabled, NM -Non configured MAC, R -Remote PE MAC, P -Pinned MAC)

 Bridging domain : V40+40, VLAN : 40, VNID : 40
   MAC                 MAC      Logical          Remote VTEP
   address             flags    interface        IP address
   80:71:1f:95:9f:f0   D                         101.101.101.1

root@SPINE-1# run show evpn database
Instance: default-switch
VLAN  DomainId  MAC address        Active source                  Timestamp        IP address
     20         00:23:9c:9d:2a:94  xe-0/0/2.0                     Oct 01 12:06:25
     20         80:71:1f:95:9f:f0  101.101.101.1                  Oct 01 10:21:58  20.20.20.100
     40         00:23:9c:9d:2a:94  xe-0/0/2.0                     Oct 01 12:01:25
     40         80:71:1f:95:9f:f0  101.101.101.1                  Oct 01 10:21:58  40.40.40.100

LEAF 1 

root@LEAF-1# run show bridge evpn arp-table
INET                MAC                Logical       Routing      Bridging
address             address            interface     instance     domain
20.20.20.1          00:23:9c:9d:2a:94  irb.20        evpn1        v20
40.40.40.1          00:23:9c:9d:2a:94  irb.40        evpn1        v40

root@LEAF-1# run show arp
MAC Address       Address         Name                      Interface               Flags
f0:1c:2d:44:a6:04 10.10.10.2      s1_itsupport.west.unisphe xe-0/0/0.0              none
00:00:5e:00:01:0a 10.85.17.1      10.85.17.1                fxp0.0                  none
d0:07:ca:57:d7:a0 10.85.17.3      10.85.17.3                fxp0.0                  none
00:23:9c:9d:2a:94 20.20.20.1      20.20.20.1                irb.20 [vtep.32769]     none
00:23:9c:9d:2a:94 40.40.40.1      40.40.40.1                irb.40 [vtep.32769]     permanent remote
02:00:00:00:00:10 128.0.0.16      fpc0                      em0.0                   none

root@LEAF-1# run show evpn database extensive mac-address 00:23:9c:9d:2a:94
Instance: evpn1

VN Identifier: 20, MAC address:: 00:23:9c:9d:2a:94
  Source: 100.100.100.1, Rank: 1, Status: Active
    Timestamp: Oct 01 11:57:49 (0x5f7626ad)
    State: <Remote-To-Local-Adv-Done>
    History db: <No entries>

VN Identifier: 40, MAC address:: 00:23:9c:9d:2a:94
  Source: 100.100.100.1, Rank: 1, Status: Active
    Timestamp: Oct 01 12:24:26 (0x5f762cea)
    State: <Remote-To-Local-Adv-Done>
    IP address: 40.40.40.1
    History db: <No entries>

SPINE-1

{master:0}[edit]
root@SPINE-1# run show evpn database extensive mac-address 00:23:9c:9d:2a:94
Instance: default-switch

VN Identifier: 20, MAC address: 00:23:9c:9d:2a:94
  State: 0x0
  Source: xe-0/0/2.0, Rank: 1, Status: Active
    Mobility sequence number: 0 (minimum origin address 100.100.100.1)
    Timestamp: Oct 01 12:06:25 (0x5f7628b1)
    State: <Local-MAC-Only Local-To-Remote-Adv-Allowed>
    MAC advertisement route status: Created
    History db:
      Time                  Event
      Oct  1 12:06:25 2020  Updated
      Oct  1 12:06:25 2020  No change to MAC state
      Oct  1 12:06:28 2020  Deleting local state
      Oct  1 12:06:28 2020  Deleting
      Oct  1 12:06:28 2020  Deleting all output state
      Oct  1 12:06:28 2020  Deleting MAC+IP advertisement route for locally learnt
      Oct  1 12:06:28 2020  Updating output state (change flags 0x0)
      Oct  1 12:06:28 2020  Active ESI unchanged (xe-0/0/0.0)
      Oct  1 12:06:28 2020  Updating output state (change flags 0x1000 <IP-Deleted>)
      Oct  1 12:06:28 2020  Clearing change flags <IP-Deleted>

VN Identifier: 40, MAC address: 00:23:9c:9d:2a:94
  State: 0x0
  Source: xe-0/0/2.0, Rank: 1, Status: Active
    Mobility sequence number: 0 (minimum origin address 100.100.100.1)
    Timestamp: Oct 01 12:24:25 (0x5f762ce9)
    State: <Local-MAC-Only Local-To-Remote-Adv-Allowed>
    MAC advertisement route status: Created
    IP address: 40.40.40.1
    History db:
      Time                  Event
      Oct  1 12:24:26 2020  Created
      Oct  1 12:24:26 2020  Updated
      Oct  1 12:24:26 2020  Updating output state (change flags 0x0)
      Oct  1 12:24:26 2020  Active ESI unchanged (xe-0/0/0.0)
      Oct  1 12:24:26 2020  Updating output state (change flags 0x800 <IP-Added>)
      Oct  1 12:24:26 2020  Updating output state (change flags 0x2000 <IP-Local-State>)
      Oct  1 12:24:26 2020  Creating MAC+IP advertisement route for locally learnt
      Oct  1 12:24:26 2020  IP host route cannot be created (no IRB interface in L2 domain)
      Oct  1 12:24:26 2020  Clearing change flags <IP-Added>
      Oct  1 12:24:26 2020  Clearing change flags <IP-Local-State>

Run the show route command on SPINE 1.

:vxlan.inet.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.10.10.0/30      *[Direct/0] 02:13:38
                    > via xe-0/0/1.0
10.10.10.2/32      *[Local/0] 02:13:38
                      Local via xe-0/0/1.0

100.100.100.1/32   *[Direct/0] 02:13:38
                    > via lo0.0
101.101.101.1/32   *[Static/1] 02:13:37, metric2 0
                    > to 10.10.10.1 via xe-0/0/1.0

bgp.evpn.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

2:101.101.101.1:1::20::80:71:1f:95:9f:f0/304 MAC/IP
                   *[BGP/170] 02:13:37, localpref 100, from 101.101.101.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.1 via xe-0/0/1.0
2:101.101.101.1:1::40::80:71:1f:95:9f:f0/304 MAC/IP
                   *[BGP/170] 02:13:37, localpref 100, from 101.101.101.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.1 via xe-0/0/1.0
2:101.101.101.1:1::20::80:71:1f:95:9f:f0::20.20.20.100/304 MAC/IP
                   *[BGP/170] 02:13:35, localpref 100, from 101.101.101.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.1 via xe-0/0/1.0
2:101.101.101.1:1::40::80:71:1f:95:9f:f0::40.40.40.100/304 MAC/IP
                   *[BGP/170] 02:13:35, localpref 100, from 101.101.101.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.1 via xe-0/0/1.0
3:101.101.101.1:1::20::101.101.101.1/248 IM
                   *[BGP/170] 02:13:34, localpref 100, from 101.101.101.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.1 via xe-0/0/1.0
3:101.101.101.1:1::40::101.101.101.1/248 IM
                   *[BGP/170] 02:13:33, localpref 100, from 101.101.101.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.1 via xe-0/0/1.0

default-switch.evpn.0: 11 destinations, 11 routes (11 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

2:100.100.100.1:1::20::00:23:9c:9d:2a:94/304 MAC/IP
                   *[EVPN/170] 00:29:07
                      Indirect
2:100.100.100.1:1::40::00:23:9c:9d:2a:94/304 MAC/IP
                   *[EVPN/170] 00:34:07
                      Indirect
2:101.101.101.1:1::20::80:71:1f:95:9f:f0/304 MAC/IP
                   *[BGP/170] 02:13:37, localpref 100, from 101.101.101.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.1 via xe-0/0/1.0
2:101.101.101.1:1::40::80:71:1f:95:9f:f0/304 MAC/IP
                   *[BGP/170] 02:13:37, localpref 100, from 101.101.101.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.1 via xe-0/0/1.0
2:100.100.100.1:1::40::00:23:9c:9d:2a:94::40.40.40.1/304 MAC/IP
                   *[EVPN/170] 00:11:07
                      Indirect
2:101.101.101.1:1::20::80:71:1f:95:9f:f0::20.20.20.100/304 MAC/IP
                   *[BGP/170] 02:13:35, localpref 100, from 101.101.101.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.1 via xe-0/0/1.0
2:101.101.101.1:1::40::80:71:1f:95:9f:f0::40.40.40.100/304 MAC/IP
                   *[BGP/170] 02:13:35, localpref 100, from 101.101.101.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.1 via xe-0/0/1.0
3:100.100.100.1:1::20::100.100.100.1/248 IM
                   *[EVPN/170] 02:13:36
                      Indirect
3:100.100.100.1:1::40::100.100.100.1/248 IM
                   *[EVPN/170] 02:13:36
                      Indirect
3:101.101.101.1:1::20::101.101.101.1/248 IM
                   *[BGP/170] 02:13:34, localpref 100, from 101.101.101.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.1 via xe-0/0/1.0
3:101.101.101.1:1::40::101.101.101.1/248 IM
                   *[BGP/170] 02:13:33, localpref 100, from 101.101.101.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.1 via xe-0/0/1.0

Run the show route command on Leaf 1.

inet.0: 12 destinations, 13 routes (12 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0.0.0.0/0          *[Static/5] 1d 03:16:35
                    > to 10.85.17.1 via fxp0.0
10.10.10.0/30      *[Direct/0] 03:10:07
                    > via xe-0/0/0.0
10.10.10.1/32      *[Local/0] 03:10:07
                      Local via xe-0/0/0.0

20.20.20.0/24      *[Direct/0] 02:19:06
                    > via irb.20
20.20.20.100/32    *[Local/0] 02:19:06
                      Local via irb.20
40.40.40.0/24      *[Direct/0] 02:19:06
                    > via irb.40
40.40.40.100/32    *[Local/0] 02:19:06
                      Local via irb.40
100.100.100.1/32   *[BGP/170] 02:54:04, localpref 100
                      AS path: 65001 I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0
101.101.101.1/32   *[Direct/0] 03:01:25
                    > via lo0.0

bgp.evpn.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

2:100.100.100.1:1::20::00:23:9c:9d:2a:94/304 MAC/IP
                   *[BGP/170] 01:56:14, localpref 100, from 100.100.100.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0
2:100.100.100.1:1::40::00:23:9c:9d:2a:94/304 MAC/IP
                   *[BGP/170] 00:39:37, localpref 100, from 100.100.100.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0
2:100.100.100.1:1::20::00:23:9c:9d:2a:94::20.20.20.1/304 MAC/IP
                   *[BGP/170] 00:01:37, localpref 100, from 100.100.100.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0
2:100.100.100.1:1::40::00:23:9c:9d:2a:94::40.40.40.1/304 MAC/IP
                   *[BGP/170] 00:16:37, localpref 100, from 100.100.100.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0
3:100.100.100.1:1::20::100.100.100.1/248 IM
                   *[BGP/170] 02:19:06, localpref 100, from 100.100.100.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0
3:100.100.100.1:1::40::100.100.100.1/248 IM
                   *[BGP/170] 02:19:06, localpref 100, from 100.100.100.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0

evpn1.evpn.0: 12 destinations, 12 routes (12 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

2:100.100.100.1:1::20::00:23:9c:9d:2a:94/304 MAC/IP
                   *[BGP/170] 01:56:14, localpref 100, from 100.100.100.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0
2:100.100.100.1:1::40::00:23:9c:9d:2a:94/304 MAC/IP
                   *[BGP/170] 00:39:37, localpref 100, from 100.100.100.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0
2:101.101.101.1:1::20::80:71:1f:95:9f:f0/304 MAC/IP
                   *[EVPN/170] 02:26:54
                      Indirect
2:101.101.101.1:1::40::80:71:1f:95:9f:f0/304 MAC/IP
                   *[EVPN/170] 02:26:54
                      Indirect
2:100.100.100.1:1::20::00:23:9c:9d:2a:94::20.20.20.1/304 MAC/IP
                   *[BGP/170] 00:01:37, localpref 100, from 100.100.100.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0
2:100.100.100.1:1::40::00:23:9c:9d:2a:94::40.40.40.1/304 MAC/IP
                   *[BGP/170] 00:16:37, localpref 100, from 100.100.100.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0
2:101.101.101.1:1::20::80:71:1f:95:9f:f0::20.20.20.100/304 MAC/IP
                   *[EVPN/170] 02:19:05
                      Indirect
2:101.101.101.1:1::40::80:71:1f:95:9f:f0::40.40.40.100/304 MAC/IP
                   *[EVPN/170] 02:19:05
                      Indirect
3:100.100.100.1:1::20::100.100.100.1/248 IM
                   *[BGP/170] 02:19:06, localpref 100, from 100.100.100.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0
3:100.100.100.1:1::40::100.100.100.1/248 IM
                   *[BGP/170] 02:19:06, localpref 100, from 100.100.100.1
                      AS path: I, validation-state: unverified
                    > to 10.10.10.2 via xe-0/0/0.0
3:101.101.101.1:1::20::101.101.101.1/248 IM
                   *[EVPN/170] 02:19:04
                      Indirect
3:101.101.101.1:1::40::101.101.101.1/248 IM
                   *[EVPN/170] 02:19:04
                      Indirect

 

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search