Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

Latest PoE firmware version availability for EX2300 & EX3400 Series Switches

0

0

Article ID: KB37317 KB Last Updated: 29 Jul 2021Version: 1.0
Summary:
This  KB article provides information on the following : 
  • Availability of the latest POE firmware version for EX2300 & EX3400 Series Switches
  • Known issues that are addressed in the latest PoE firmware version
  • Relevant steps that are needed to be taken to upgrade the switch to the latest PoE firmware version.
Symptoms:

The latest PoE firmware version for EX2300 & EX3400 Switches is "2.1.1.19.3"

The new POE firmware version is available from the following Junos releases :

  • 15.1X53-D59
  • 18.1R2
  • 18.2R1
  • 18.3R1

The current version of PoE firmware could be determined by running the CLI command "show chassis firmware detail"

     EX2300> show chassis firmware detail
               FPC 0
                PoE firmware            2.1.1.19.3
                Boot Firmware
                U-Boot                   U-Boot 2016.01-rc1 (Nov 11 2016 - 14:26:00 -0800)  1.3.2
                Boot Firmware
                loader

 

Cause:

The latest PoE version 2.1.1.19.3 addresses a known issue that was seen on older POE firmware version such as 1.6.1.x.x where the non-ieee compliant PoE Powered Device (PD) in some cases were not able to receive power from the POE Controller of EX2300 and EX3400 series switches. The behaviour of these non-ieee compliant PoE powered devices may lead to a false positive underload latch if the EX2300 or EX3400 runs with PoE Firmware version 1.6.1.x.x.  In other words,  PoE underload latch generally indicates that the PoE device is not properly drawing PoE power and that power should not be delivered.

Solution:
This issue of non-ieee compliant PD’s reporting false positive Underload Latch is addressed through external PR1345234. Refer to link below for more information on this issue : 
https://prsearch.juniper.net/InfoCenter/index?page=prcontent&id=PR1345234
 
This issue is resolved through a new POE firmware version 2.1.1.19.3 for EX2300/EX3400 Series switches.

To upgrade the PoE Firmware on EX2300 and EX3400 series switches, perform the below mentioned steps during a scheduled maintenance window :

Step 1 : Upgrade the EX2300/EX3400 series switch to the Junos release which contains the new PoE Firmware. POE firmware version 2.1.1.19.3 is available from Junos 15.1X53-D59 , 18.1R2, 18.2R1, 18.3R1 onwards.

Step 2 : Verify the current junos version and firmware version using the following commands :
              show version all-members 
              show chassis firmware  

Note : 
Once you have upgraded the EX2300/EX3400 switch to the Junos version that contains the package for the new PoE firmware image, then running the 'show poe controller' CLI command will provide a similar alert for the availability of the new PoE version as shown below (highlighted in blue) : 
labroot@EX3400 > show poe controller 
‚Äč
Controller  Maximum   Power         Guard    Management   Status        Lldp
index       power     consumption   band                                Priority 
   0**       0W       0.00W           0W                  AT_MODE       Disabled
  **New PoE software upgrade available. 
 Use 'request system firmware upgrade poe fpc-slot <slot>' 
 This procedure will take around 10 minutes (recommended to be performed during maintenance)

Step 3 :  Issue the following command to upgrade the firmware version :
              "request system firmware upgrade poe fpc-slot <slot-number | all-members>"

Note : 
The fpc-slot number should be '0' in case of standalone chassis. You need to change the fpc-slot number accordingly if it is part of a virtual-chassis.
Also, it is recommended that you push the PoE code one by one instead of adding all members in the virtual-chassis setup.

Step 4 :  Reboot the system.

Step 5 :  Verify if the PoE firmware has got upgraded successfully :

               EX2300> show chassis firmware detail
               FPC 0
                PoE firmware            2.1.1.19.3
                Boot Firmware
                U-Boot                   U-Boot 2016.01-rc1 (Nov 11 2016 - 14:26:00 -0800)  1.3.2
                Boot Firmware
                loader

 
 
 
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search