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Syslog message: 'sbus ack not received within configured time'

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Article ID: KB37475 KB Last Updated: 13 Sep 2021Version: 1.0
Summary:

This article discusses the following syslog error, which is seen on QFX5110 platforms:

Jul 29 12:35:48.371  Switch : %PFE-3: fpc0 sbus ack not received within configured time.

Symptoms:

On QFX5110 platforms, the following messages are seen on the syslog:

Jul 29 12:35:48.370  Switch : %PFE-3: fpc0 0:_cmicm_sbusdma_reg_array_read:
Jul 29 12:35:48.371  Switch : %PFE-3: fpc0 L2_ENTRY.ipipe0 failed(ERR)
Jul 29 12:35:48.371  Switch : %PFE-3: fpc0 0:cmicm_sbusdma_error_details:
Jul 29 12:35:48.371  Switch : %PFE-3: fpc0 sbus ack not received within configured time.

Jul 31 14:08:27.426  Switch : %PFE-3: fpc0 0:_cmicm_sbusdma_wait:
Jul 31 14:08:27.426  Switch : %PFE-3: fpc0 failed(ERR)
Jul 31 14:08:27.427  Switch : %PFE-3: fpc0 0:cmicm_sbusdma_error_details:
Jul 31 14:08:27.427  Switch : %PFE-3: fpc0 0:_cmicm_sbusdma_reg_array_read:
Jul 31 14:08:27.427  Switch : %PFE-3: fpc0 Received sbus ack has wrong opcode.
Jul 31 14:08:27.427  Switch : %PFE-3: fpc0 0:cmicm_sbusdma_error_details:
Jul 31 14:08:27.428  Switch : %PFE-3: fpc0 Received sbus ack data size is not the same as in rep_words fields.
Jul 31 14:08:27.428  Switch : %PFE-3: fpc0 0:_soc_sbusdma_desc:
Jul 31 14:08:27.428  Switch : %PFE-3: fpc0 soc_sbusdma_desc:IP COUNTERS Error
Jul 31 14:08:27.428  Switch : %PFE-3: fpc0 0:_soc_sbusdma_port_ctr_cb:
Jul 31 14:08:27.429  Switch : %PFE-3: fpc0 Counter SBUSDMA failed: port:17.
Jul 31 14:08:27.429  Switch : %PFE-3: fpc0 L2_ENTRY.ipipe0 failed(ERR)
Jul 31 14:08:27.429  Switch : %PFE-3: fpc0 0:cmicm_sbusdma_error_details:
Jul 31 14:08:27.429  Switch : %PFE-3: fpc0 sbus ack not received within configured time.
Cause:

The CMIC DMA error messages and the L2_ENTRY error messages are related. They appeared to have occurred due to high load on L2_TABLE access. As a result, the CMIC did not receive the proper ACK messages within the set timeout interval for the DMA-requests that it had issued. This is the reason for the logging of these error messages.

Solution:

If these messages are seen intermittently, they can be ignored. It does not interrupt service and is gracefully handled by the device.

If they are are seen continuously, contact your JTAC Representative to investigate further.

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