Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

The QSFP-100G-PSM4 could not be correctly identified on QFX5200-32C-32Q platform

0

0

Article ID: TSB17962 TECHNICAL_BULLETINS Last Updated: 18 Jan 2021Version: 1.0
Alert Type:
PSN - Product Support Notification
Product Affected:
QFX5200-32C-32Q
Alert Description:
This technical support bulletin (TSB) has been opened to inform Juniper Networks customers that a new jfirmware image with updated optics CPLD version has been released for the mentioned QFX platforms.  It is advised that you upgrade to this jfirmware image in case if you are experiencing the reported issue with the QSFP-100G-PSM4 optics. 

On QFX5200-32C when frequent hot swap of optics module happens, the QSFP-100G-PSM4 could become undetected and related links won't come up. In the problem state the previously working QSFP-100G-PSM4 might start to show part-number as ‘NON-JNPR’ & part description as ‘UNKNOWN’. The corresponding physical interfaces will remain down.
I2C failure errors could be seen in the logs.  
Solution:

This problem is seen due to Optics CPLD Firmware contains the I2C clock stretch issue. The optics CPLD firmware upgrade is necessary to fix the I2C access issues seen from HW for PSM4 optics.

The updated Optics CPLD version is available through jfirmware package. To download the jfirmware package, please click on the URL below :  

Image Name : qfx-5e-firmware-18.4I20191126_1116_panshah.tgz
MD5 : d0a48d4f5ac950f92bd868983bae83ec
URL : https://webdownload.juniper.net/swdl/dl/secure/site/1/record/101164.html


Note : Manual power cycle of the device is required to upgrade the jfirmware package. 

 
Implementation:

To upgrade the Jfirmware package on QFX5200, please follow the guidelines below : 
 

Step1 : Verify the CPLD version on the device
lab@QFX5200> show chassis firmware | match “Version|FPC|Optics”

Part                     Type            Version

FPC 0                    U-Boot             ***                                       
                         Optics CPLD        6.1.6   <<<<<<<<<<<<<<<<<<<<<<<<<<<<< Old Optics CPLD Version.     

 

Step 2 : Add the latest firmware package : 
cli> request system software add <firmware pkg> 

Step 3 : Proceed with the manual power cycle of the device. 

Step 4 : Verify the Optics CPLD version again .
root@jtac-qfx5200-32c-32q-r2019> show chassis firmware | match “Version|FPC|Optics”

Part                     Type             Version
FPC 0                    U-Boot           ***                                                                      
                         Optics CPLD      6.1.7    <<<<<<<<<<<<<<<<<<<<<<<<<< New Optics CPLD Version.
                                   
                         
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search